file Frage meine ersten Tage

Mehr
05 Apr 2016 18:04 - 05 Apr 2016 18:07 #32864 von alpenkreuzer
alpenkreuzer antwortete auf meine ersten Tage

MagIO2 schrieb: Ich würde sagen es ist ein Software-Bug, wenn das Modul anfängt zu spinnen, nur weil die Kommunikation wegfällt. Das Modul könnte genausogut an der letzten Koordinate stehen bleiben. Und mit etwas mehr Aufwand in WinPC sollte sogar ein resume möglich sein.


Und ich würde sagen: es ist kein Software-Bug. Auch bei einer "etwas besseren" Steuerung (triple Beast) passiert gar nichts mehr, wenn wenn die Kommunikation wegfällt. Allerdings bleibt das TB dann auch an der letzten Koordinate stehen.

Zum funktionslosen Notaus will ich mal lieber garnix weiter sagen, das ist einfach nur peinlich und darf auf keinen Fall passieren!


Beim TB funktioniert in solchen Fällen das Notaus immer noch; nur WinPC-NC nimmt - logischerweise - keine Befehle mehr an.

Mir scheint, daß die berichteten Fehlfunktionen bei Irma entweder

- durch statische Aufladung bedingt sind (war ein Staubsauger im Einsatz, was wurde gefräst?)
- oder durch schlechte USB-Verbindung (Kabel, Wackelkontakt) ausgelöst werden
- oder durch beides.

Edit: Sehe gerade in einem Irma-Post: kein Kunststoff, kein Staubsauger

Gruss Michael

begonnen mit 420/2, Alu-Fräse "KARLA" (noch im Bau)
EstlCam mit Arduino NANO, WinPC-NC USB
Kress, QCAD, Fusion 360, Inventor, Winghelper
Letzte Änderung: 05 Apr 2016 18:07 von alpenkreuzer.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
05 Apr 2016 18:11 #32865 von alpenkreuzer
alpenkreuzer antwortete auf meine ersten Tage
Noch eine Bemerkung zu den Windows-Stromsparfunktionen:

Man kann im Gerätemanager gezielt für jede USB-Schnittstelle angeben, ob die Energieverwaltung für diesen Anschluss abgeschaltet werden soll oder nicht.

Gruss Michael

begonnen mit 420/2, Alu-Fräse "KARLA" (noch im Bau)
EstlCam mit Arduino NANO, WinPC-NC USB
Kress, QCAD, Fusion 360, Inventor, Winghelper

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • MagIO2
  • MagIO2s Avatar
  • Offline
  • Forum Nutzer
  • Forum Nutzer
  • Zu viele Ideen und zu wenig Zeit
Mehr
05 Apr 2016 18:43 #32866 von MagIO2
MagIO2 antwortete auf meine ersten Tage

alpenkreuzer schrieb:

MagIO2 schrieb: Ich würde sagen es ist ein Software-Bug, wenn das Modul anfängt zu spinnen, nur weil die Kommunikation wegfällt. Das Modul könnte genausogut an der letzten Koordinate stehen bleiben. Und mit etwas mehr Aufwand in WinPC sollte sogar ein resume möglich sein.


Und ich würde sagen: es ist kein Software-Bug. Auch bei einer "etwas besseren" Steuerung (triple Beast) passiert gar nichts mehr, wenn wenn die Kommunikation wegfällt. Allerdings bleibt das TB dann auch an der letzten Koordinate stehen.


Kommunikation fällt weg -> Steuerung fährt bis zu letzten bekannten Position -> OK
Kommunikation fällt weg -> Steuerung macht nix mehr (und man muss alles ein-/ausschalten)-> ist zumindest ein durch bessere Programmierung zu behebendes Defizit
Kommunikation fällt weg -> Sogar der Notaus geht nicht mehr -> Eindeutig ein BUG, der bei einer größeren Maschine lebensgefährlich wäre

Das schöne am Entwicklerleben ist doch, dass man sich nicht mit dem zufrieden geben muss, auch wenn es alle anderen genauso machen. Ich sehe keinen Grund etwas mehr Hirnschmalz in die PC - Steuerungs-Kommunikation zu investieren um sowas dann auch gleich sicher und restart-fähig zu machen.

Irmas Problem ist doch so gut wie sicher identifiziert -> Energiesparfunktion, sie schreibt ja, dass sie sich in beiden Fällen wieder anmelden musste.

SC 420 mit DIY parallel + Proxxon mit Mod + HF500 + SprintLayout + LibreCAD/QCAD + FreeCAD +WinPC starter/USB->EstlCAM + EstlCAM LPTAdapter + EstlCAM Handrad + DIY Vakuumtisch

Gruß, Andreas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
05 Apr 2016 19:53 #32868 von ubo
ubo antwortete auf meine ersten Tage
Da mir einiges doch recht merkwürdig vorkam habe ich es mal auf die Brutale Art getestet. Einfach den USB Stecker beim Programmlauf abgezogen.

Hier die Ergebnisse:
Kommunikation fällt aus -> Maschine arbeitet 3 sek das Programm weiter ab und bleibt stehen
Kommunikation fällt aus dann Nothalt betätigt -> Maschine steht sofort

Demzufolge funktioniert der Nothalt (so wie es auch sein sollte) unabhängig von der Maschinensteuerung.

Irma du solltest deinen Nothalt mal testen, nicht das da etwas falsch angeschlossen ist.

Gruß,
Uwe

WinPC-Nc V4, EstlCAM V11
www.ubo-cnc.de
Folgende Benutzer bedankten sich: MagIO2

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

Wir benutzen Cookies

Wir nutzen Cookies auf unserer Website. Einige von ihnen sind essenziell für den Betrieb der Seite, während andere uns helfen, diese Website und die Nutzererfahrung zu verbessern (Tracking Cookies). Sie können selbst entscheiden, ob Sie die Cookies zulassen möchten. Bitte beachten Sie, dass bei einer Ablehnung womöglich nicht mehr alle Funktionalitäten der Seite zur Verfügung stehen.