file Frage Difference between Y-axis with Performance Kit

Mehr
21 Mär 2022 15:47 #62223 von bsv116
I have a strange phenomenon where there is a difference of ~6.3 mm in travel distance between the two Y-axis. Here are some details:
- Machine: Stepcraft-2/D.840 upgraded with the Performance Kit.
- Replicate problem: 1. Home, 2. Jog all the way down the Y-axis (~836 mm), 3. Measure the distance between the front panel and gantry.
- In spite of the difference there is no emergency stop, as should be when the Y-axis gets out of sync.
- If the Y-axis does get out of sync there is an emergency stop, so the sensors are working properly.
- When untightening the rollers or adding more grease on the lagging side, it makes no difference.

When doing some calculations, I found the following:
- The gantry moves 0.0075 mm per step.
- The travel distance is 836 mm.
- 0.0075 x 836 = 6.27
- Could it be so that one of the steppers is losing one step per millimetre?
- If so, could it be a firmware problem or a stepper problem?

Any suggestions on the cause of the phenomenon would be much appreciated.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

Wir benutzen Cookies

Wir nutzen Cookies auf unserer Website. Einige von ihnen sind essenziell für den Betrieb der Seite, während andere uns helfen, diese Website und die Nutzererfahrung zu verbessern (Tracking Cookies). Sie können selbst entscheiden, ob Sie die Cookies zulassen möchten. Bitte beachten Sie, dass bei einer Ablehnung womöglich nicht mehr alle Funktionalitäten der Seite zur Verfügung stehen.