file Question UCCNC Softlimit

  • Rajivraj
  • Rajivraj's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
26 Jan 2017 00:13 #43207 by Rajivraj
UCCNC Softlimit was created by Rajivraj
Hello,



I am running a sample G code that came with the step craft, its the step craft logo.



I have an error message that says "The current job Workspace is out of the set software limits. Adjust the soft limits to fit the job extents or disable soft limits."



Prior to this error message.
I was able to Home all axis to the zero position. All axis moves freely without any binding, reaching its limits and stopping and moving again . The machine works fine, till you start loading in the G codes.



These are the following steps that i have taken to run the machine using the sample G code provided and my own G codes.



1.Load Sample G code

2.Zero my axis to the workpiece i am cutting

3.Cycle start to execute G Code

4. Error Message ""The current job Workspace is out of the set software limits. Adjust the soft limits to fit the job extents or disable soft limits."

5. Clicked on Configuration tab>>> General settings>>>Uncheck "Enable softlimits"

6. Click on Tab "Apply Settings"

3. Click on "Cycle start"

4. Reset Switch Starts Blinking with error message "

"THE RESET LOGIC OF THE SOFTWARE IS ACTIVE! REMOVE RESET CONDITION WITH PRESSING THE BLINKING RESET BUTTON THE SCREE. iF THE REST CONDITION CANNOT BE REMOVED DUE TO AN EXTERNAL E-STOP BUTTON IS PRESSED IN OR A LIMIT SWITCH ON THE MACHINE TOOL IS ACTIVE.PLEASE CHECK DIAGNOSTIC FOR THE INPUT SIGNALS CONDITION"

5. I have checked the E-Stop button, all the limit switches and they are all okay.

6. Clicked on "OVERRIDE LIMITS"

7. Reset stops blinking

8. Clicked Cycle start

9. Error Message "The current job Workspace is out of the set software limits. Adjust the soft limits to fit the job extents or disable soft limits."



Please advice

Rajiv

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

More
26 Jan 2017 08:38 - 26 Jan 2017 08:45 #43211 by DerRoy
Replied by DerRoy on topic UCCNC Softlimit
Hi Ravjivraj,

the coordinates on the first picture: Are these machine coordinates? (It doesn't look like)
When you set the Y-Axis to zero, + Values for Y should go to the rear (where the connectors are). Which means in the front, or at your 0 point it should be possible to move to the direction of the connectors. Your picture is already showing Y-Axis to be on postition 597, which means no movement left.

What could also be one mistake: The 0 Point of the Logo is not on the lower left corner. Pls. Try to set your 0 point to somewhere in the middle of your workspace, zero X and Y and set Z zero point high enough above the plate and run a test without cutting. You can see if it starts to run to the left and not to the right. Which would show 0 is on the lower right corner.

BR
Roy

MfG
Roy

SC 600/2; SolidWorks; UCCnC und UC100; EstlCam und Arduino Steuerung; KRESS 800kfme;
Last edit: 26 Jan 2017 08:45 by DerRoy.

Please Log in or Create an account to join the conversation.

More
26 Jan 2017 09:29 #43214 by SiSt
Replied by SiSt on topic UCCNC Softlimit
Hi Ravjivraj,

Which version of UCCNC are you using? You could try to install the newest version from cncdrive.com in a separate folder and try whether it fixes the issue. (There was a bug regarding the soft limits, see: forum.cncdrive.com )

SiSt

SC 2/420, HF Spindel, UCCNC

Please Log in or Create an account to join the conversation.

  • Rajivraj
  • Rajivraj's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
30 Jan 2017 20:22 #43509 by Rajivraj
Replied by Rajivraj on topic UCCNC Softlimit
Hi Roy,

I have disabled the soft limits and the machine works.

when i go to the very back position, i.e is when i do the home all axis my machine cordinates are x=0 y= 597 and z= 0.

Is this right.

I have to disable the soft limits to be able to run the machine. When i enable the soflimits i have the error as i explained before. I have done what you have suggested, putting the machine in the middle and starting the job, the workpiece is far smaller as well. I zeroed all the axis in the middle before commencing the job.

It seems the issue is when the soft limits are enabled..

any suggestions

Please Log in or Create an account to join the conversation.

More
30 Jan 2017 21:16 #43513 by DerRoy
Replied by DerRoy on topic UCCNC Softlimit
I guess we need to check your setup for the axis.
Could you make screen shots of the set-up screens for all axis?
Which machine you have? Looks like the SC2/600.
Did you usedo the Stepcraft Screenset.exe for setting up the machine?

BR
Roy

MfG
Roy

SC 600/2; SolidWorks; UCCnC und UC100; EstlCam und Arduino Steuerung; KRESS 800kfme;

Please Log in or Create an account to join the conversation.

More
28 Nov 2022 08:03 #62739 by Naturalwood37
Replied by Naturalwood37 on topic UCCNC Softlimit
Hello friends, I'm new here, I have the machine m1000 It's been a year now and I've been encountering a problem exceeding restrictions every time and every time it's in a certain vintage this time z And this time y .... It is possible to know where the problem comes from, I would be happy to give advice

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.