file Question Laser will not start at all during a cycle

More
30 Apr 2018 00:30 #53616 by [email protected]
Hi,


Few days ago I did all the setup of the laser and got it working. I did a couple of tests with good results. Today I was planning to keep on practicing with the laser but the laser itself does not turn ON at all during the cycle also the operating LED does not turn ON.

As I said; the cycle starts, the machine starts moving but the laser wont turn ON. I reinstalled the laser UCCNC software, restarted the computer but it does not work.

I am sure the key on the laser box is on the ON position and the cable between the Laser and the machine is also connected well.

Attached is the screenshoot of the diagnostics taken when it was running the cycle but no laser. Not seen in the photo but O16 and O17 keep blinking red very fast while it was running.

I will appreciate your help.

Thanks

This message has an attachment image.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

More
06 May 2018 20:38 #53684 by bmartens
Replied by bmartens on topic Laser will not start at all during a cycle
Hi there,
Common things being common, most likely the tiny switch at the base of the laser switch isn't being fully depressed by the housing.

For the laser to turn on,
1) The Laser module needs to be plugged into the stepcraft base
- (sometimes this is forgotten, if you're going back and forth from milling)
2)Key needs to be turned on
3) tiny switch at base of laser needs to be depressed by the housing (fully insert the laser into the orange holder)
4) height switch needs to be in the 'sweet spot'
- with the laser turned on
- fully extend the height switch on the laser all the way down
- slowly slide it back up until it is mostly up - there will be a point the blue guide laser turns on - this is where to leave this switch.

===
5) UCCNC needs to be started in the LASER profile. (not the normal Stepcraft profile used for milling/dragknife/etc)
- this means that when UCCNC sees the turn laser on command, it's translated into the actual signal on the correct pin to turn the laser on

6) The g-code needs to have the correct code to turn the laser on & off
(if you're using the test code from the manual, this will work.
M10 turns the laser on, and M11 turns it off
- the way the correct G-Code is created is by whatever program you're using using the correct post-processor selected. If this is the case, and you can't sort it out, let us know if you're using Vectric, Fusion, Inkscape, or something else.

With all of these correct, you *should* have things working OK.

Please Log in or Create an account to join the conversation.

More
07 May 2018 15:45 #53689 by [email protected]
I found the problem!

The key switch where the blue key is inserted seems to be a little sensitive. Apparently I was not turning it ON all the way. Even though the vacuum started the laser did not. There is a very small position of the switch where this scenario happens.

After knowing this I was able to use it without any issues.

Thanks for your help!

Please Log in or Create an account to join the conversation.

More
07 May 2018 16:48 #53690 by bmartens
Replied by bmartens on topic Laser will not start at all during a cycle
Interesting - It would have taken me a while to get to an issue like that too.
I'm glad you've come to a relatively simple problem that can be fixed.
Cheers

Please Log in or Create an account to join the conversation.

More
13 May 2018 04:17 #53738 by [email protected]

bmartens wrote: Interesting - It would have taken me a while to get to an issue like that too.
I'm glad you've come to a relatively simple problem that can be fixed.
Cheers


Hi bmartens,

I had the same problem again and I was wrong it is Not the key switch. I had the same issue and toggling the switch did nothing. So, I decided to open the control box. I found that the key switch is just a Normally Open contact that closes when the key is turned ON. This also turns ON the vacuum and the vacuum always turns ON/OFF. So, for sure the issue is not what I mentioned before. This is either open or close, ON or OFF and it is working fine.

I am starting to think it is the cable between the control box and laser tool. Because I got it working after moving the control box to a different place thus changing the path of the hose. I will try it again next week and whenever I confirm or find the issue I will post it here.

Thanks,

Please Log in or Create an account to join the conversation.

More
21 May 2018 20:55 #53792 by laranja169
Replied by laranja169 on topic Laser will not start at all during a cycle
Hello,
Thank you for your post, because I've the same exactly problem, and i verify everything,
-verified everything menthion above,
-verified if the tool Lengh sensor unpluged
-verified the control box, and the cables to the laser, but i dont want to open the laser due to warranty... Unfortunetly tody and yesterday, I try to call Stepcraft a lot of times, and my WoodBurning service to my client is soooo late!

Can someone please help?

Please Log in or Create an account to join the conversation.

More
28 May 2018 09:20 #53826 by seracraft
Replied by seracraft on topic Laser will not start at all during a cycle
Need Laser Profile please anybody send me the file to my mail ID This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

More
28 May 2018 14:25 #53827 by [email protected]

seracraft wrote: Need Laser Profile please anybody send me the file to my mail ID This email address is being protected from spambots. You need JavaScript enabled to view it.


hi,

check your email, spam folder if you do not see it.

regards
Nestor Aguilar

Please Log in or Create an account to join the conversation.

More
28 May 2018 16:14 #53828 by [email protected]

[email protected] wrote: I found the problem!

The key switch where the blue key is inserted seems to be a little sensitive. Apparently I was not turning it ON all the way. Even though the vacuum started the laser did not. There is a very small position of the switch where this scenario happens.

After knowing this I was able to use it without any issues.

Thanks for your help!


THIS WAS NOT THE ISSUE
PLEASE KEEP READING BELOW
THE CAUSE OF THE ISSUE IS STILL UNKNOWN!

Please Log in or Create an account to join the conversation.

More
More
20 Feb 2020 20:30 #58267 by [email protected]
hi all,

newbee with the laser, I get the same problem.
- switch key ok,
- vacuum on, ok
- i/o setup & spindle configuration checked
- Estop (off) ok
- Laser Probe & macro m31 run correctly ;
-- after m31 execution, the little blue laser is on : ok ; good setting
- goto zero , Z=top of surface ok (the little bue laser turn off)
when I run the g-code, all run correctly except the laser did not turn on...
the g-code is the test one correct and contain M3/M10Qnn / G0xy / M11/M5

I do not open the controler, may I nee to check some cabling ?
thanks for any help.
manu

manufv

Please Log in or Create an account to join the conversation.

More
22 Feb 2020 18:14 #58288 by [email protected]

[email protected] wrote: hi all,
manu


ok, solved.¨
I used UCCNC 1.2111, these release change the method to define CurrentHiLo. The input fields moved from I/OSetup to AxisXYZABC (6 differents CurrentHiLo); ...
But I use UC100 and this one manage only one CurrentHiLo then UCCNC 1.211x merge the definition ... 6 to 1 and everthing is okay.
laser turn correctly on.

! but, to be able to define it correctly, I must use the UCCNC Default screen set and NOT the stepcraft one which is out-of-date.

How to use stepcraft machine profiles with default screenset ?
edit ..\UCCNC\Profiles\Stepcraft2_Model840.pro with notpad.exe
set the mainscreenfilename=Defaultscreenset (2sd line)
save and start uccnc with the stepcraft profile.

For sharing.

manufv

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.