file Question X-Achse "springt" beim fräsen

  • Gorly
  • Gorly's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
25 Jun 2023 17:39 - 25 Jun 2023 18:53 #63228 by Gorly
X-Achse "springt" beim fräsen was created by Gorly
Hallo zusammen,
ich hab heute mal wieder meine Steppi in Gang gesetzt und wollte mein CAM-Problem lösen.
Das hat auch soweit alles geklappt (nach reichlich Buddelei in diversen Einstellungen).
Jetzt habe ich als Test eine kreisförmige Tasche mit 2 mm Tiefe als Fräspfad aufgesetzt und das Ding laufen lassen.
Direkt beim ersten Versuch ist dabei mitten in der Kreisbewegung die X-Achse "gesprungen" - heißt, sie ist ca. 3-4 cm weiter gefahren als sie sollte.
Ok, geguckt, ob der GCode Mist ist - aber alles in Ordnung.
Gleiche Datei noch 5 mal ablaufen lassen und alles funktionierte wie es sollte.
Hat jemand eine Idee, woran so etwas liegen könnte, bzw. wie ich so was in Zukunft verhindern kann?
Ich vermute, dass da irgendwas mit der Codeverarbeitung gelaggt und die Maschine kurz keine Positionsdaten zurückbekommen hat.
Referenzierungen haben sich jedenfalls nicht verschoben, da die Folgeversuche an der definierten Stelle gefräst haben.

Edit:
So, hab jetzt noch einen Versuch gemacht. Geplant war eine 6 mm tiefe Tasche (100 x 100mm) und innerhalb dieser Tasche noch eine kreisrunde Senkung auf 10mm, alles adaptives clearing. Was soll ich sagen...es wurde ein Massaker. Die X-Achse ist WIEDER bei der Kreisfräsung gesprungen (2x) und hat die Werkstückdimensionen dabei verlassen.
Beim zurückfahren scheint dann noch die Z-Achsen-Position verloren gegangen zu sein und beim nächsten Versuch ist dann der Fräser voll in die Opferplatte gerumpelt. Not-Aus.
Ich musste mich grade echt zusammenreißen, um dem Ding nicht eine Bello-Spezialbehandlung zu verpassen.
Die ersten 4-5 Fräsungen liefen toll und seitdem hab ich mit der Maschine nur Ärger. Wäre super, wenn mir hier irgendjemand etwas Hilfestellung geben könnte.
Last edit: 25 Jun 2023 18:53 by Gorly.

Please Log in or Create an account to join the conversation.

More
25 Jun 2023 21:01 #63230 by Labo2222
Replied by Labo2222 on topic X-Achse "springt" beim fräsen
Hi,

was für eine Maschine ist es denn? Evtl. kannst du mal versuchen die Achsen der Maschine zu Erden. Versuche mal den Anschluss an jeweils einer Schraube des Schrittmotors mit Kabelschuh und Zahnscheibe (alle Achsen). Wenn die Maschine hin und wieder seltsame dinge macht, bei denen sich kein genaues Schema abzeichnet, kann es evtl. an statischer Ladung liegen. Das könntest du mit zusätzlichen Erdungen evtl. in den griff kriegen.

Ob dass das Problem ist, weiß ich leider nicht. Aber eine zusätzliche Erdung (bzw. Potentialausgleich) kann mit einfachen und günstigen Materialen umsetzten.

Gruß
Patrick

Please Log in or Create an account to join the conversation.

  • Gorly
  • Gorly's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
25 Jun 2023 22:48 #63231 by Gorly
Replied by Gorly on topic X-Achse "springt" beim fräsen
Ist ne D840/2 mit AMB Spindel.
Das mit der Erdung kann ich mal versuchen - Material hab ich hier rumliegen.
Was mich halt völlig irritiert ist das "springen". Ich würd es ja mechanisch verstehen, wenn das Ding "hängen" würde, aber so...
Noch ein paar Zusatzinfos: ich nutze WinPCNC in der USB-Variante mit 'nem relativ "alten" Schleppi, falls das irgendwas zur Lösungsfindung beitragen kann.
Den GCode aus Fusion hab ich schon geprüft, der ist völlig normal, was ja auch die Fräsergebnisse bei dem ersten Taschentest gezeigt haben. Kann ich also als Fehlerquelle ausschließen.

Please Log in or Create an account to join the conversation.

More
26 Jun 2023 11:58 #63232 by Labo2222
Replied by Labo2222 on topic X-Achse "springt" beim fräsen
Das sind doch schon mal ein paar Infos.
Ich bin leider kein Freund der D2, da hat sich bei Stepcraft von D2 zur D3 viel getan.

Ich würde wie bereits geschrieben mal einen Test mit verbesserter Erdung durchführen. Evtl. kannst du auch mal versuchen die Spindel zu Erden.
Ich glaube dass bei der D2 die 43mm Spannaufnahme mit Pulverbeschichtet ist und somit das Erdungspotential der Maschine nicht bis zum Fräser übertragen wird. Hier kannst du evtl. eine feindrähtige Aderleitung mit in den Spannhals klemmen. Sollte zum testen genügen.

Was mir bei meiner M Serie aufgefallen ist, dass das Win PC NC Modul von Stepcraft fehleranfälliger ist als das USB Modul von der Firma Lewetz selbst.
Seit ich das USB Modul von Lewetz nutze läuft die Maschine erheblich stabiler. Allerdings benötigt man dann bei der D2 noch das Parallelportmodul soweit ich weiß.

Achte auch mal darauf, ob es "Sprünge" in den Koordinaten sind oder Schrittverluste der Motoren. Insbesondere die Y-Achsen sind bei den D2 Maschinen durch den Riemenantrieb etwas schwach motorisiert und neigen gerne mal zu Schrittverlusten.

Gruß

Please Log in or Create an account to join the conversation.

  • Gorly
  • Gorly's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
26 Jun 2023 12:22 #63235 by Gorly
Replied by Gorly on topic X-Achse "springt" beim fräsen
Ich glaub ich mach als nächstes erstmal ein paar Trockentests ohne Fräser mit entsprechender Erdung. Vielleicht hilft das ja.
Mal gucken, ob ich im Hintergrund noch ne Screencapturing-Software laufen lassen kann...da sollten ja dann Koordinatensprünge nachvollziehbar werden.
Man sollte echt nicht meinen, dass sich so 'ne poplige Portalfräse so immens von 'nem 3D-Drucker unterscheidet, ist ja eigentlich das selbe Bewegungsprinzip. Bei meinen Drucker hab ich so ein Geschiss nicht.

Please Log in or Create an account to join the conversation.

More
26 Jun 2023 12:30 #63237 by Labo2222
Replied by Labo2222 on topic X-Achse "springt" beim fräsen
Es hat leider seine Gründe warum ich kein Freund der D2 bin.
Bedenke aber bei der Trockenübung, das durch die fehlende Reibung und den nicht entstehenden Staub bzw. Späne
auch die statische Ladung evtl. nicht auftritt und demnach evtl. auch keine Probleme auftreten.

Aber Trockenübung ist grundsätzlich eine gute Idee....langsam rantasten...

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.