file Question Toolchanger achsenproblem

  • Dentopt
  • Dentopt's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
18 May 2023 10:42 #63137 by Dentopt
Toolchanger achsenproblem was created by Dentopt
Ich verwende eine M500 mit toolchanger.
Die Referenzfahrt macht sie immer hinten links (0,0,0).
Wenn ich die Fräse nach vorne bewege, ist laut uccnc y negativ.
Ganz vorne ist ungefähr y=-520mm..

In gcode ist es aber genau umgekehrt. Vorne ist 0 und hinten ungefähr 520mm.

Problem ist, die toolchanger macros verwenden gcode coordinaten.
Deshalb sucht die Maschine die Tools immer an der handgefertigt Stelle.
Habt ihr irgend eine Idee, wie man das umstellen kann?

Beste Grüße

Please Log in or Create an account to join the conversation.

More
19 May 2023 18:15 #63144 by ubo
Replied by ubo on topic Toolchanger achsenproblem
Du must einfach nur die Achswerte bei der Referenzfahrt anpassen. Y muss bei der Referenzfahrt nicht zwingwnd 0 sein es kann auch 520 sein.

Gruß,
Uwe

WinPC-Nc V4, EstlCAM V11 / V12
www.ubo-cnc.de
The following user(s) said Thank You: Dentopt

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.