file Question Nach Endschalter Y-Achse reagieren andere Endschalter für 2 Minuten nicht

  • Martin Stahl
  • Martin Stahl's Avatar Topic Author
  • Offline
  • Forum Nutzer
  • Forum Nutzer
More
19 Jun 2023 07:56 #63216 by Martin Stahl
M1000 mit WinNC PC USB Aufbau

Hallo Zusammen,

Nachdem der Endschalter der Y Achse links ausgelöst worden ist (egal ob vorne oder hinten) nimmt Wimnc PC keinen weiteren Schalter Input an. Nach ca 2 Minuten Wartezeit geht es dann wieder. Das macht es unmöglich bei der Referenzfahrt eine andere Reihenfolge der Achsen zu wählen bei der Y nicht die letzte ist, da mach der Y Referenzfahrt die anderen Achsen den Endschalter nicht mehr annehmen.

Hat dazu jemand eine Idee?

Ich werde bestimmt in nächster Zeit noch ein paar Anfänger fragen stellen müssen. Schon mal danke im Voraus für Eure Geduld mit mir.

Martin

Please Log in or Create an account to join the conversation.

More
21 Jun 2023 13:48 #63219 by Burkhard
Hallo,
bei den Stepcraft-Maschinen sind elektrisch alle Schalter parallel auf einen Eingang geschaltet und deshalb kann die Steuerung nicht unterscheiden, welche Achse und auf welcher Seite der Endschalter angefahren ist. Um weitermachen zu können muss zuerst wieder der Schalter frei sein.
Gruß
Burkhard

Please Log in or Create an account to join the conversation.

More
22 Jun 2023 19:28 #63225 by Hubaer
Habe das gleiche Problem bei meiner M.1000 jetzt bei dem Aufbau.

Ich betätige jeden der Y1 oder Y2 Taster - WinPC zeigt es im Signal Assistenten an. Drücke ich dann die beiden Z oder X Endschalter sehe ich das ebenfalls. Danach keine Signaldarstellung mehr wenn ich einen der Y Taster drücke - egal welche. X - und Z Schalter sind noch sichtbar.

Wenn ich mit einem Messgerät den Widerstand auf den Eingangsklemmen Y1 oder Y2 Endschalter test habe ich immer Durchgang, egal ob ich eine Taste drücke.
Vor dem Problem oder im Ausgeschalteten zustand kann ich den Schalterdruck auf dem Eingang messen.

Somit geht jede Referenzfahrt in die Hose und auf der Achse bewegt sich entweder ein oder kein Motor.

Ich nehme das jetzt auch und melde es dem Support

Grüße Ingo

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

© 2022 STEPCRAFT GmbH & Co. KG

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.